albatrosary's blog

Azure と Angular と Wercker CI とか

いくらユーザが古いブラウザを使っていてもサポートしちゃいかんよ

タイトルの通りです。「いくらユーザが古いブラウザを使っていてもサポートしちゃいかんよ」です。以前から方々で言われている通りで記事も多くあります。よく言われるのが「ある程度動けば」とか「機能が落ちても」というような話がありますが、そういう問題では無いです(下記記事を読めばわかる)。

ざっくり言うと、サポートされていない古いブラウザを使い続けるとマルウェアへの感染などリスクが高まる等脅威があり、そうしたブラウザをユーザへ供用することは間接的に加害者になる、などなど。

Web を何かしらで生業にしている会社なら当たり前のような気がします。ので適当にピックアップしたサイトの推奨環境を見てみます。

サイト 最新を推奨しているか 推奨環境URL
Yahoo Yahoo! JAPANヘルプセンター - Yahoo! JAPANの推奨ブラウザー
楽天 × 楽天ネットスーパー ヘルプページ
バイク王 よくいただくご質問・お問い合わせ(FAQ) | バイク王
amazon Amazon.co.jp ヘルプ: Amazon.co.jpがサポートしているブラウザについて
suumo 推奨環境 | リクルートホールディングスの不動産・住宅サイト SUUMO(スーモ)

楽天。。。そっそすか、、、まさかの、、、はい、、、
あくまでも想像ですが、楽天でも何かしらのことをしていて、ただ単に記載変更漏れだと思います(と信じたい)。だとすると、記載と事実が異なるというのも好ましい状態ではないと思います。

もうすぐIE9も終了します。Webエンジニアたるもの強い意志をもって屈せず対応しよう

Internet Explorerサポートポリシー変更の重要なお知らせ - Microsoft

Vistaのサポートも4月11日終了するので同時にIE9のサポートも終了です

サポート終了に関するよくあるご質問 | Microsoft

Windows Internet Explorer 延長サポート終了
Windows Vista SP2 Internet Explorer 9 2017年 4 月 11 日
Windows Server 2008 SP2 Internet Explorer 9 2017年 4 月 11 日
Windows 7 SP1 Internet Explorer 11 2020年 1 月 14 日
Windows Server 2008 R2 SP1 Internet Explorer 11 2020年 1 月 14 日
Windows Server 2012 Internet Explorer 10 2023年 1 月 10 日
Windows 8.1 Internet Explorer 11 2023年 1 月 10 日
Windows Server 2012 R2 Internet Explorer 11 2023年 1 月 10 日
Windows 10 Internet Explorer 11 (最低でも10年)

※ Windows8はWindows8.1へのアップグレードが必要

https://blogs.msdn.microsoft.com/osamum/2015/10/01/2016-1-12-internet-explorer/ より